[bisq-network/support] @huey735 10.01 (#337)

huey735 notifications at github.com
Mon Feb 10 22:30:58 UTC 2020

### Description

The user first posted on the #general channel on Keybase on February 9th 2020 at 16h52m and both me and @leo816 responded within the minute.
They claimed that their taker fee transaction couldn't be found on a bock explorer but that they had already sent the fiat to the other trader.

After talking with them I learned that they sent more than requested by Bisq causing an invalid trade.

**Current status**: offer taker, btc buyer, sent fiat to offer maker, btc seller, without having a valid trade and therefore a valid multisig binding them.

#### Version

Bisq v0.9.5

### Steps to reproduce

Take an offer and instead of the value requested in the Bisq software, send that plus a under the dust value to that address. So if it says that you should fund the address X with 0.012993 btc, send instead  0.012995 btc. Adding 200 sats. 

### Expected behaviour

A not "expected", but ideal behaviour would be: if amountSent to address X is superior to the amountRequired and the diffrence between amountSent and amountRequired is equal or inferior to the dust limit, then this difference should be added to the mining fees of the transaction. If the difference is superior, a third output should be created sending this amount to the taker.

### Actual behaviour

The trading fee tx for the taker is created and splits the inputs into predetermined output amounts:
output 1 - trading fee
output 2 - security deposit + trade amount (if btc seller) that will be sent to the multisig
Normally those would be the only outputs, but in this case an extra 200 sats are unaccounted for and instead Bisq creates a third output sending 200 sats to one of the taker's addresses. This creates an invalid transaction that can't be broadcast to the network due to the dust output.

The Bisq v1.2.5, where I ran the test, recognizes immediately. The user was using Bisq v.0.9.5

### Screenshots

Image 01 - immediately after making the transaction from an external wallet to take the offer


Image 02 - after closing the first pop-up


Image 03 - after closing the second pop-up if we go to PORTFOLIO > OPEN TRADES we see this

Image 04 - after restarting the software and going to PORTFOLIO > OPEN TRADES we are presented with this

#### Device or machine


#### Additional info

I tried to run tests on the Regtest but my knowledge was limited. If I try to make a transaction inside Bitcoin Core with a dust output I'll get an error. But following the steps above, Bisq is able to create it and relay it through the network and finish the trade successfully. On my Bisq wallet I'll have a valid dust output.

I wasn't able to properly monitor the maker side of things due to low time and high fees but I'm looking forward to it to see if there are ways in which we can rectify mistakes like this.

You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bisq.network/pipermail/bisq-github/attachments/20200210/d22b03c4/attachment.html>

More information about the bisq-github mailing list