[bisq-network/bisq] Unable to access wallet details via Bisq app due to Java heap space error (#5579)

pazza notifications at github.com
Sun Jun 20 07:09:53 CEST 2021

### Description

I am unable to access wallet details from the Bisq app.

Both 'ctrl + J' and Account > Wallet Info > Show raw wallet details are private keys.

On doing either of the above CPU and RAM usage spikes and Bisq crashes. Sometimes an error message is produced, other times Bisq just hangs.

I have tried adding to the command line prompt:
`start "" Bisq.exe [JAVA_TOOL_OPTIONS="-XX:MaxRAM=32g"] -bypassMempoolValidation=true`
`start "" Bisq.exe [JAVA_TOOL_OPTIONS="-XX:MaxRAM=32g"] `
`start "" Bisq.exe -bypassMempoolValidation=true`

But all instances of Bisq run using the above still end up failing when calling wallet details.

The above issue means I am unable to access PrivateKeyHex for a trade I would like to make a manual payout for.

#### Version


### Steps to reproduce

The issue is a problem with my Bisq instance. 

I have tried on a separate instance and am able to access wallet details.

Not sure if it is due to a corrupted wallet, a wallet that is too large, or my system not being powerful enough to open my wallet details.

### Expected behaviour

Wallet details is displayed using either 'ctrl + J' or Account > Wallet Info > Show raw wallet details are private keys.

### Actual behaviour

Bisq crashes every time wallet info is called. Must have tried 50+ times.

When an error massage is shown it is a Jave heap space error:

![java heap space](https://user-images.githubusercontent.com/66367547/122662770-8f515c80-d18d-11eb-8959-685c7f09e2b6.PNG)

I have tried suggestions in in issue #5550 (see command line prompts above) to no avail.

#### Device or machine

CPU: Intel(R) Core(TM) i9-10900K CPU @ 3.70GHz
RAM: 32 gb
Graphics: NVIDIA GeForce RTX 2070 Super
OS: Windows 10 Pro

#### Additional info

Logs can be provided on request.

You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bisq.network/pipermail/bisq-github/attachments/20210619/998572b2/attachment.htm>

More information about the bisq-github mailing list